Getting your Grobo back online

Hi everyone,

I’m working with some of the people that purchased the Grobo assets from bankruptcy. I’d like to help you get your units working again.

The short, short version is: Your units should work, and you can manage them through the webapp. I see at least half a dozen or so people running grows successfully right now.

The longer version is: The iOS app is offline and I’m trying to get it working again. There are also some serious maintenance problems with the backend, some of which cause database calls to take between 4 seconds and 2 minutes. (For reference, database responses should generally be 100ms or less.)

I’ve put together a full FAQ that I’ll post below, and I’ll make available on the grobo and CitizenGrown websites. You can email me at info at grobo io, but I’d prefer to keep conversations here so that we can help each other.

Also, if someone can shoot me a link to the Discord (or at a minimum, post this there) I’d appreciate it!


What happened?
Grobo filed for bankruptcy in December 2021 and their assets went to auction. An investment group won the assets, which included the servers, source code, and design files.

Why did Grobo file for bankruptcy?
Sorry, we don’t have specifics.

Can I get a refund?
With regret, no. The Grobo company went out of business and no longer exists. The new owners of the Grobo assets are working towards getting your Grobo operational.

Will my Grobo work?
While we can’t make any guarantees or take on obligations of the bankrupt Grobo company, some Grobos are still growing, right now. We are carefully getting the systems and apps back online with the expectation that, unless a unit is in need of repair, it will be able to grow again.

Can I get repair, service, and support?
The engineering team working to get Grobos working is presently just one very enthusiastic person, but yes we are working on this. Email us at info at grobo io, or post in one of the active communities

How do I get my Grobo working today?
If your wifi hasn’t changed, you should still be able to manage your Grobo at If your unit has been or needs to be reset, you can get the Android app in the Google Play store, and follow the instructions there. The App Store/iOS app is a bit more involved for us and we are working on it.

What about nutrients?
The community at Allgrowers has some recommendations. We are not endorsing these, but it seems that some people are having success. We will be selling nutrients in the future and will let you know when this occurs.

Will you sell new Grobos?
The new owners of the Grobo assets have a somewhat different business model. You can read about it at CitizenGrown, But the plan is: yes.

What happens if this happens again?
We are working on ways to open source some of the software and break the reliance on centralized servers. Anyone who loves emerging technology has been disappointed by a company going under and the devices becoming bricked, and that includes us. Once you buy an appliance, it should work like a microwave, even if the company that made it goes under.

Why now?
It takes time to complete the auction, take possession of assets, inventory, find the right team to get things up and running, learn the source code, etc. We wanted to engage the community as soon as we had any news, and this is it.

We want to hear from you…
We are doing our best to get your units operational again, but we need to know what you need. You can reach us at info at grobo io, but the most active forum right now seems to be Allgrowers.


I’m on reddit and on the discord as CitizenGrobo.

My grobo webpage is logged in an working via my iPhone on safari but I randomly just sunday my light hasn’t been on for its regular scheduled lighting time

I tried unplugging reconnecting WiFi readjusting the lighting schedule under settings etc nothing solved the issue

But when I open the units door or use my mirror glass function the light turns on momentarily

So how can we solve my issue?

Email [email protected] and I’ll see what the system thinks is happening.

Something I’ve already found is that some units are trying to talk to the debug/QA servers and I haven’t gotten those online yet.

1 Like

Ok sent a email hopefully you guys can get me back an operational before my plant dies

I found one issue- someone had been shipped a replacement motherboard. This motherboard looks like it was still in the QA configuration. Normally they should be flipped to Production before being installed in a unit or sent to a customer.

The QA environment was not operational since I didn’t think we needed it yet. It lost DNS due to expiring domains but did some sleuthing and I’ve got some of it reconfigured now.

One cool thing about this replacement unit is it is running on the ESP32 board. I didn’t know those had ever been shipped out. I am discovering lots of this kind of stuff as I go.

Right now I am just waiting on cloudflare to publish the new DNS entries. This might fix a number of people that were not working.

The database is coming to its knees because of some unindexed queries. I need to add indexes, but the right way to do that is with a deployment. The build infrastructure does not work due to revoked credentials so I’ll work on that next.

I got a request to display last known PH on the dashboard. It looks pretty straightforward to do, but that comes from one of the tables that is very slow.

If you email me, make sure to include the email address you use to sign in.


1 Like

A lot of us received the gen 2 version which was completely unusable for most of us. It randomly drained water on to all of our floors, the fans went out on us, our air filters stopped sucking in air, when we went to drain and fill u had to turn the box off 2-3 times to stop it from drain or filling! Not to mention the wifi connection on them is sorry! Its a mess they never could fix or figure that out for us. We all were doomed with gen 2s! Oh i forgot 1 more thing! When it randomly decided to drain it would also suck every bottle of nutrient bone dry!

1 Like

That’s crazy. Really sorry to hear about that. I’ll look into the draining issue after I get some more people online.


The server might be down/offline some today (march 21st) while I add indexes to the database. It should improve getting some errors, but it’s going to make troubleshooting issues people are having much faster for me (so I can fix more)

1 Like

Lights are back on for me

but my airstone isn’t aerating

I have heard about aerating problems from a couple of people now. I did another DNS fix today and it has started working for at least one person. Let me know if it starts working for you.

The “bomb cyclone” here in san francisco cut me off from the database while running a backup so the maintenance window is extending into tomorrow. I’m on generator power now and I’m running backups correctly this time :sweat_smile:. I have tested the fix for DB timeouts pretty extensively while waiting so I feel good about it. More updates as they come.

If you’ve emailed me and I haven’t gotten back to you yet, sorry for the delay, I’ll get back to you asap. Thanks everyone!


Really appreciate your efforts and selflessness in helping out.
Thank you. We’re getting some of that weather in AZ today.
I have a grobo that grew a couple of grows. But I shut it down shortly after small problems started arising.
I’m following along and want to use it again but I’m waiting for more certainty.
Again thank you for your help here.


Great work! Thanks so much for keeping us growing. I spent the ‘cyclone’ up in Tahoe, looking out the window. :hushed:
Ill try to get my unit up and running again tonight.

I fixed a major bug today that was preventing me from talking to grobos. The bug was: There was an authorization check on the server that checked for admin privileges before letting someone send messages to grobos they don’t own. (like me)

Although I have an admin role, it wasn’t the first role on my account since I started as a grobo customer in 2021… so this failed. I changed it to check for all the roles to see if one of them was admin.

Making progress! I can now communicate with your units.


@Grobo I just started a new grow and I am unable to get it working. The box worked for me up until 3 weeks ago.

I have not ‘reset’ it with the app, how do I do that?

@crasch I think grobos are having trouble getting their schedules from the server. Which server, I have no idea. Still working on that.

Big update copied from Discord:

I think the issue a lot of people having right now are that the grobos can’t get their schedules from the server. I can’t figure out what server they are trying to reach, but I think they’re getting an error when they do.

I’m doing a little bit of reverse engineering: connecting to the serial port (the little USB connector on the motherboard) and using what’s called a man-in-the-middle attack (Man-in-the-middle attack - Wikipedia) on my grobo to see all the network traffic. I have the source code but without the insider knowledge of the grobo engineers I don’t know exactly which configuration is on physical grobos in the wild.

Meanwhile I can turn on lights and aeration pump manually from here. I’m going to try to expose these controls to everyone (reading pH was also requested) so at the minimum you could do a manual grow inside the grobo.

The way to give everyone control of their grobo without the grobo servers at all is through → there are some rudimentary controls there and I’ll publish the format and instructions for manually sending commands directly to the firmware. It’s going to be a while for this though. It also needs a new firmware that will, for example, just get its schedule from a file located in a public github repository.

At least one person may have a faulty motherboard or grow light. I spoke to the manufacturer today and I’m planning to go through the grobo inventory to see what spare parts we can get. If you think you have bad hardware, email me and you can ship me your motherboard to test.

Another thing I’ve done is instrumented the infrastructure. I’ve been fixing a ton of errors (software exceptions) that were being silently squashed. Having analytics is important and has helped me track down things like 10 minute database queries (which are now running in ~20 milliseconds) and I’ve been able to see server errors happen before people even reach out to me.

Apologies if I’m slow to respond on Discord or Email.

1 Like


I dont think i have bad hardware since it was all working till whatever happened a few weeks ago that killed (or halted) a bunch of our grows.
I have a full set of spare parts if I need anything.

My unit is working except for the pump and light. The light responds to draining and filling with colored lights, and cycles when i restart the unit.
Oh yeah; also drain and fill no longer seems to trigger auto dosing, if that helps problem solving in anyway.

Thanks, and please let me know if you need any info from me to help get my unit running again.

I have 2 machines that have not worked in a year, Just opened the app by chance and it worked, trying to start a grow after a deep clean. Can you also look into the calibration of PH and EC. That was always done on the phone with the morons at Grobo when most of us understand what were looking at. Just a thought. Ill keep you posted on how it works and what does and does not happen automatically.

1 Like

I think I just fixed the main issue units were having.

The short version is: Providers started doing things like turning off DNS since they weren’t getting paid from a company that didn’t exist anymore. How capitalist of them.

I started piecing things together and inferring what configuration should be. This mostly worked.

The brain in the grobo motherboard has a cloud provider that uses secure communication, but when the grobo tries to ask grobo servers what the schedule should be, that’s over HTTP because the space we have in the firmware is too tiny to do things like HTTPS certificates. The firmware is something like 64 kilobytes.

So this was hitting the DNS provider, cloudflare, and cloudflare was trying to redirect the units to HTTPS. Their tiny brains didn’t know what to do about this.

This made it so I didn’t see anything when the grobo tried to get the schedule.

So I changed the cloudflare configuration to hit the api server directly instead of letting them route it. Now I could see the units attempting to get their schedules.

And it worked!

You should be able to fully manage your grobo schedule and recipe now!

I am working on getting spare parts. More updates as I have them.

As usual, let me know if you have any problems. Thanks everyone that has been helping and reporting issues!


Can you also look into the calibration of PH and EC.

I don’t even know what this means so I’ll need a lot of help.

Most of their support documentation was lost after payment lapsed and the 3rd party support provider wiped their data. There are some internal documents though.

I’ve had a lot of requests to expose the raw ec and ph value and that’s the next feature I’m going to add. If there are commands for doing the calibration in firmware, I’ll open those up as well.