Grobo ph and Ec probes

Hey everyone is there a alternative to the grobo probes if they go bad I know you should change ph every year and EC probe every 2 yrs please help

1 Like

The Grobo PH an EC probes are made by a company called Blue lab and can be purchased on Amazon.ca or .com :wink: Also I think I seen a previous post of yours asking about the Grobo start nutrient Packets, I seen some available on Amazon as well but limited quantity.

Hope this helps.

                              Mr.420 ;)
1 Like

I see blue lab ph probe but not the EV probe of possible can u put link here’s for EC probe

I just noticed the EC probe from Bluelab isn’t on amazon or sold out, I seen it last night. But I do see others, let me look into this one and see if any other Brands are compatible.

For now this is the Bluelab web page they would be the ones to get it from.

Home | Bluelab Canada

                                     Mr.420
1 Like

I didn’t compare part numbers but this should work fine

1 Like

Don’t see EC probe on blue labs can someone put link to it up here please!! Definitely see the PH probe

#7

- - - [2022-01.21]:

@Suffland1109,


.


.

.


.

.

.

~~~

- - - [2022-02.02]:A

@doverosx,


.
Sorry..~~ (5)
.


.

.

~~~

- - - [2022-02.02]:B

@Bandit,


.

  • (You Are One Of The Lucky Ones To Have This Option, -But- Still should Not Have Happened):

.

~~~

- - - [2022-02.02]:C

@John0086,

.


.

.

~~~

- - - [2022-02.03]:


.


.


.


.

  • (#TeamHasGotYouCovered): {Green_Thumb..~~ (3)}:

.

~~~

- - - [2022-02.23]:

@Tebori,

.


.

.
--

:wink: :smiling_face_with_three_hearts: :+1:t5:


~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~

4 Likes

I installed that bluelab probe into my grobo but the app continues to say it needs calibration after every time I check.

I had that same issue last year. I had to replace a circuit board.

I had the same issue with a bluelabs pH probe I got off Amazon a couple months ago. I think I must have recalibrated it 10 times before it finally succeeded. All my pH standards (7.0 & 4.0) were fresh. Maybe just keep trying to calibrate

1 Like

Now that’s interesting!

I’ll give it a whirl!

2 Likes

Well I’ll be damned, it passed the check right off the bat! I suspect that I didn’t let the probe reach the appropriate temperature range since it was -20C where I live.

6 Likes

Tip…

Make sure you leave your probe in solution for at least 5 mins even longer is better before you start calibrating… It takes a bit for probes to get stable. Make sure your solution temp is around 70 ºF temp plays a roll on Ph also

3 Likes